Canon EOS 400D & EFS 17-85mm Err99

15 09 2009

Er99The symptom:

My Canon EOS 400D (XTi in the states) along with my EFS 17-85mm f/4-5.6 was giving the famous Err 99 – “Shooting is not possible. Turn the power switch to <OFF> and <ON> again or re-install the battery” when I fully depressed the shutter button. It did not do it at all times, and also the problem did not occur with my EF 50mm f/1.8.

The problem:

I found through a process of elimination that the problem (Err 99) would only occur on the wide angle (17-35mm) when using an aperture smaller than f/4. So I guessed that either the lens was the problem, or perhaps the communication between the lens and body. I cleaned the contact points with an eraser… but no go… same problem.

The solution:

Took both the out-of-warranty body and lens into the Canon Service Centre in Singapore. They found the problem to be with the len’s power diaphragm assembly, and replaced it as a cost of S$111.28 (Part S$24, Labor S$80 & GST S$7.28). They also did a great job cleaning the internal lens elements and external housing, so it looks as good as new now.

Unrelated they found my focus screen on the body to be really scratched too, and replaced it for S$26.75 (Part S$5, Labor S$20 & GST S$1.75).

Image credit to Rowen Atkinson

Advertisements

Actions

Information

One response

15 09 2009
Flickr Upload: Fly by Night « l00pback

[…] Update: got that Err99 fixed! […]

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s




%d bloggers like this: